Moderate Outage

Incident Report for Payhawk

Resolved

The issue causing the outage has been fully resolved. All services are now operating normally. We’re monitoring the system to ensure continued stability.
Posted May 13, 2025 - 12:15 UTC

Investigating

We are aware of a partial service disruption affecting specific functionalities. Our team is actively working to rectify the issue. We appreciate your patience as we work to restore full service.
Posted May 13, 2025 - 11:58 UTC
This incident affected: Card Authorization, Core API, and Developer API.