Elevated API Errors
Incident Report for Payhawk
Resolved
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Nov 17, 2023 - 09:43 UTC
Investigating
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Nov 17, 2023 - 09:42 UTC